Anaconda3 Navigator doesn't launch Jupyter Notebook

I can’t launch Jupyter Notebook from Anaconda3 Navigator. After I install it I click Launch, a blue bar appears saying it is Launching the Notebook and after a while it goes away again but nothing happens.

When I want to close Anaconda Navigator I get a message saying

image

Even though I can’t see where this is happening.

Can someone help me? I spent the whole afternoon googling this error but I didn’t find a solution. I have also installed and re-installed multiple times.

You don’t need to use Anaconda3 Navigator to launch Jupyter Notebook.

Type the following in terminal:

jupyter notebook

Or you can read the documentation on how to open Jupyter Notebook jupyter notebook.

Jupyter Notebooks launch on your default web browser. You might want to check on the tabs of your default web browser.

If that does not work, then try re-install Jupyter Notebook only. You do not need the entire Anaconda package.

Installing Notebook via pip on the terminal

pip install --setup upgrade pip
pip install notebook 

Running notebook on the terminal:

jupyter notebook

Installing notebook via conda

Read guide to use conda to install Jupyter notebook

1 Like

If you have anaconda properly installed

you can open jupyter notebook using “Anaconda prompt”

  • Click Window Key
  • Search for “Anaconda prompt” and open
  • now type “jupyter notebook” and Enter
1 Like

Thank for the input of both, I can use jupyter using the prompt.

I have tried to reinstall the Navigator launcher for jupyter but wasn’t successful, I suppose the error is with the Navigator but I am just too frustrated to keep trying to figure it out so I will just stick with using prompt.

1 Like

Strongly suggest to move on. Don’t waste your time on resolving how to get navigator launcher working for Jupyter notebooks. Almost everyone launches the notebook from the terminal. It’s easier and lesser work.

1 Like

Hi joao_caldinhas,

I have been facing the same kind of issue while trying to launch Jupyter Notebook or JupyterLab from Anaconda Navigator app for windows. After getting into here, I followed DishinGoyani suggestion and ran Anaconda Prompt, just to find out there were two other instances already open. At the end, the prompt was able to launch a new instance at another port, but the Navigator itself remained stuck and did not respond when I tried to launch jupyter from there.

1 Like

Use the last two links with localhost:8890 or 127.0.0.1:8890 . Either one should work.