BLACK FRIDAY EXTRA SAVINGS EVENT - EXTENDED
START FREE

Can't connect on certain missions?

Hi, I’m trying to do the Python Data Analysis Basics mission, but can’t seem to connect to the virtual machine from my desktop. Other missions seem to work, while others don’t as well. The object-oriented mission doesn’t connect anymore either.

I’ve tried from my laptop, and I’ve tried running code from another mission and going back to the ones that don’t work but they still don’t seem to be connecting. I’ve tried firefox and chrome, neither work. Does anyone know why this would be happening?

Hey @mattc.carreon!

Do you mind trying a hard refresh and see if that helps to fix the issue? Let me know.

Mary

I tried hard refreshing and hard refreshing + clearing cache as well, sorry forgot to mention that! The object-oriented python mission seems to be working now as well, but the data analysis one still isn’t. I was doing the data analysis basics mission on a public computer at my school yesterday, but I logged out so I’m not sure if that may have messed with the connection.

Hi @mattc.carreon,

Please provide me links to the mission screen that is not working.

Thanks,
Sahil

@Sahil

https://app.dataquest.io/m/331/python-data-analysis-basics/2/calculating-artist-ages

Sorry, it said it connected to the VM and I thought it was working again but it actually isn’t.

Hi @mattc.carreon,

Our engineering team is investigating this issue. To collect more details about this issue, We need your help. Please follow the below steps:

  1. Go to Dataquest Dashboard
  2. Run this code in your browser console: localStorage.setItem("socket_info_debug", 1)
  3. Open the mission screen that is timing out
  4. Run the code that produced the time out error
  5. Reply to this message after you did the above steps
  6. Go back to browser console and run: localStorage.setItem("socket_info_debug", 0)
  7. Refresh the page

Screen Recording
CloudApp

How to open the console of your browser?

Chrome

keyboard shortcut :

Firefox

keyboard shortcut :

The Firefox browser console and web console can both be used to view errors. The difference is the web console offers a command line for entering JavaScript.

IE8, IE9, IE10, IE11, Edge

keyboard shortcut : F12

IE8

menu location : Tools > Developer Tools > Script tab > Console tab
https://msdn.microsoft.com/en-us/library/dd565625(v=vs.85).aspx

IE9, IE10, IE11

menu location : Menu cog icon > F12 Developer Tools > Console tab
https://msdn.microsoft.com/en-us/library/bg182326(v=vs.85).aspx

Edge

menu location : Menu “three dots” icon > F12 Developer Tools > Console tab
https://dev.windows.com/en-us/microsoft-edge/platform/documentation/f12-devtools-guide/

Opera

keyboard shortcut :

  • Ctrl + Shift + J (Windows/Linux)
  • Command + Option + J (Mac)
    menu location :
    The Opera developer tools must be enabled before use.
  1. Menu > More tools > enable “Show developer menu”
  2. Menu > Developer > Developer Tools
    https://developers.google.com/web/tools/chrome-devtools/debug/console/console-ui?hl=en

Safari

keyboard shortcut : Command + Option + C
menu location :
The Safari developer tools must be enabled before use.

  1. Safari > Preferences > Advanced > enable “Show Develop menu in menu bar”
  2. Develop > Show Error Console
    https://developer.apple.com/library/safari/documentation/AppleApplications/Conceptual/Safari_Developer_Guide/GettingStarted/GettingStarted.html#//apple_ref/doc/uid/TP40007874-CH2-SW1

Thanks,
Sahil

1 Like

Hi - I’m suddenly having the same issue with the Data Analyst in Python path (Course 1 / Functions: Intermediate). I am using Chrome.

I did what Sahil suggested and attached screenshots. I’ve reloaded the page multiple times and there seems to be an issue with cookies and cross-site requests. I also see something about unexpected tokens.

Has there been a recent update?

Screen Shot 2020-05-26 at 9.21.33 PM

Hi,

I have gone through the troubleshooting steps above and also those listed in the Dataqueset documentation - here is the error currently received. Not running any of my own code and have tested on multiple missions:

image

Is there an issue with the DQ backend at the moment? Not seeing anything posted to status.dataquest.io recently, but thought I would check.

Thanks,

-Peter

1 Like

I am also experiencing connection issues and hard refresh etc. not helping

image

I’m not able to get the localStorage.getItem command to work