Completed guided project missing

Hi,
I have completed both Clean And Analyze Employee Exit Surveys and Answering Business Questions using SQL. When I click on Learn data science with Python and R projects, it should normally open my solution to the project Answering Business Questions using SQL, instead it opens my solution to Clean And Analyze Employee Exit Surveys. My Jupyter notebook solution to the SQL project mentioned above is lost somehow.
Also, the project Clean And Analyze Employee Exit Surveys loads an older version saved 2 weeks ago. I have completed the project and saved it before sharing in the community for review. Everything is totally messed up - A missing project and loss of all my work on another project though it was saved.

Could you please help me out here @Sahil ?

Thanks,
Anjali

hey @menon.aj

this post has links to original posts about saving and recovery. not sure how much they would help you though in this scenario.

Thanks @Rucha but sadly it’s not helping. :worried:

I find that strangely all most of my projects are messed up. When I open SQL Guided project say, Answering Business Questions using SQL the Jupyter notebook opens the notebook for Guided Project: Popular Data Science Questions. Same goes with a few other. I’m attaching the screenshots here so that you can see what I mean.

Any workaround on this?

Also, I’m not able to save my work. On trying to save, the I see Bad Gateway as seen in the image attached and in the end lose all the work done.

I am unable to proceed further with the current project I’m working on. Please help.

hey @menon.aj

Unfortunately, I never worked on any project directly on DQ. I always used a notebook on my local machine. So I don’t have any real experience with regard to these issues.

@Zubair, @april.g, @Prem any ideas?

any solution for the problem yet?

1 Like

hey @menon.aj

I have never really worked on a project on the DQ platform, barring a couple of test codes here and there. I started working directly on locally installed Jupyter Notebook. So I have no real idea about the issue itself.

Did you rename the file while working? (maybe that’s why the same project is visible on all your projects page) There are several other posts on DQ community about this, perhaps you can try some workaround from there.

Sahil will join us back on 18th, so any possible recovery from DQ backend might have to wait till then. :slightly_frowning_face:

No, I haven’t renamed the file. Guess I’ll wait until Sahil is back.

1 Like

Hi @menon.aj,

Sorry about that! Our platform doesn’t support opening on multiple Guided Projects at once:

Here is the project file that I was able to recover for Mission 191:
191.zip (981.0 KB)

Can you please send me a list of projects that are overwritten? Please make sure to open it one by one.

Best,
Sahil

2 Likes

Hi @Sahil,

Thanks for the info on opening multiple projects.

I find the following projects, either missing or overwritten:

  1. Mission 356 - Exploring Hacker News Posts
  2. Mission 348 - Clean And Anlayze Employee Exit Surveys

And of course, Mission 191 for which you have already provided the project file above.
Thanks

Sorry @Sahil, but I just realised that the project you recovered and shared above is an incomplete project whereas I have already completed Mission 191. Any ways to recover my completed project file?

Hi @menon.aj,

As I couldn’t find the correct version of your project, I have attached all the versions that I was able to download for the projects 191, 356, 348. I really wish that your project is not lost.

Best,
Sahil

2 Likes

Thanks @Sahil. I have all the missing projects recovered. Much appreciated.

1 Like

Good to know and thanks to the recovery