I can't install packages in R

Hello, I’ve just started taking courses on dataquest and I can’t download packages in R. On my computer I use the command “install.packages” and it works normally.

My Code:

install.packages("readr")

Output:

Installing package into ‘/usr/local/lib/R/site-library’
(as ‘lib’ is unspecified)

Warning message in install.packages("readr"):
“'lib = "/usr/local/lib/R/site-library"' is not writable”
Error in install.packages("readr"): unable to install packages
Traceback:

1. install.packages("readr")
2. stop("unable to install packages")

Thanks

I am assuming it’s intentional that you can’t install anything through the DQ terminal.

There shouldn’t be a need to do that since they make sure to include all packages that are required by the content. It could also be a safety/security reason to not allow learners to install any package at any time.

If you wish to install packages, then you will have to continue doing that on your own system.