I think there's something wrong with the platform

I think there’s something wrong with step 10 and 11 in the Multiple Plots mission. My code looks the same as the solution provided but for some reason, it keeps telling me that my plot doesn’t match the expected output.

Dataquest plot
Screen Link:
https://app.dataquest.io/m/143/multiple-plots/11/final-tweaks

My Code:

fig = plt.figure(figsize=(10,6))
colors = ['red', 'blue', 'green', 'orange', 'black']
for i in range(5):
    start_index = i*12
    end_index = (i+1)*12
    subset = unrate[start_index:end_index]
    label = str(1948 + i)
    plt.plot(subset['MONTH'], subset['VALUE'], c=colors[i], label=label)
plt.legend(loc='upper left')
plt.title('Monthly Unemployment Trends, 1948-1952')
plt.xlabel('Month, Integer')
plt.ylabel('Unemployment Rate, Percent')
plt.show()

What I expected to happen:
I expected to pass the exercise

What actually happened:

Your 1st plot doesn't match what we expected.

Apparently this is a bug that was already solved.

Check this topic.

Copy the whole answer of the DataQuest into the editor to bypass the error. Your code may be correct but that is not what the system expect. I hope it helps.

I think there’s something wrong with step 10 and 11 in the Multiple Plots mission. My code looks the same as the solution provided but for some reason, it keeps telling me that my plot doesn’t match the expected output.
https://app.dataquest.io/m/143/multiple-plots/11/final-tweaks
fig = plt.figure(figsize=(10,6))
colors = [‘red’, ‘blue’, ‘green’, ‘orange’, ‘black’]
for i in range(5):
start_index = i*12
end_index = (i+1)*12
subset = unrate[start_index:end_index]
label = str(1948 + i)
plt.plot(subset[‘MONTH’], subset[‘VALUE’], c=colors[i], label=label)
plt.legend(loc=‘upper left’)
plt.title(‘Monthly Unemployment Trends, 1948-1952’)
plt.xlabel(‘Month, Integer’)
plt.ylabel(‘Unemployment Rate, Percent’)
plt.show()

What actually happened:

Your 1st plot doesn't match what we expected.

seems like bug has not resolved.
1 Like

Hi @mansi.trivedi,

Sorry about that, the bug is not fixed yet. Please try this workaround to mark the screen as completed:

Best,
Sahil