Intro to SQL - CIA Factbook GP - Empty Database - Factbook.db

https://app.dataquest.io/m/257/guided-project%3A-analyzing-cia-factbook-data-using-sql/2/introduction

Hello ,

Not able to open factbook.db in guided project
PLs see attached file of initial coding in jupyter notebook on local machine.

Kindly help to resolve the issue.
Thanks,
Umesh

Analyzing_CIA_Factbook_Data_Using_SQLite.ipynb (2.2 KB)

Click here to view the jupyter notebook file in a new tab

hi @exports

you database “factbook.db” is somehow empty. You are able to connect with and open it. But it doesn’t have any tables or other definitions.

Can you re-download the database again, place it in the same folder the project notebook file and then try to re-run these steps?

When I run your query (I copy pasted your query in my notebook) on sqlite_master table I get the below result. However in your case you get an empty sqlite_master.

If the re-download doesn’t work, then please detail all the steps in sequence that you followed, so that we can try to replicate the error at our end.

Thanks Rucha for quick reply.

Already downloaded again and then after i posted here.
pls see attached file that i downloaded ahgain - factbook.dbfactbook.db (66 KB)

hey @exports

This connects too and shows 3 tables. So this database should also work.

thanks a lot. now it works .
may be bcoz of same file downloaded from multiple sources in which one is empty or different reason !
Anyway thanks, again

1 Like