Ipython-sql Installation

I’m currently starting the Guided Project: Analyzing CIA Factbook Data with SQL.
I tried using the following code lines in the Anaconda based Jupyter:

!conda install -yc conda-forge ipython-sql
%%capture
%load_ext sql
%sql sqlite:///factbook.db

They did not work. The Anaconda Jupyter does not respond to the last 3 command lines above.

I’ve decided to use the DataQuest Jupyter platform.

Hi @sbgraham72:

Please try to install the package via anaconda prompt instead (enter conda install -yc conda-forge ipython-sql):

(base)$ conda install -yc conda-forge ipython-sql

and there after restart jupyter and omit the syntax, similar to what is described in this thread.

In future, please attach the mission link as per these guidelines so we know the particular mission you are referring to. Thanks!

Thanks. I tried that and the response was that I don’t have write permissions to the target environment. environment location: C:\ProgramData\Anaconda3.

The “closest” I could get to (base) was C:.

Bruce

Hey, Bruce.

This means that your user on Windows isn’t allowed to place files on that directory. You’re missing permissions.

If you have the power to do so, I suggest you run Anaconda Prompt as an administrator. If you don’t, then you’ll probably need the help of a user with administrator privileges.