Irrelevant Python error occurring in each and every mission

Screen Link:

My Code:

opened_file = open('AppleStore.csv')
from csv import reader
read_file = reader(opened_file)
apps_data = list(read_file)
non_games_ratings = []
for row in apps_data[1:]:
    rating = float(row[7])
    genre = row[11]
    
    if genre != 'Games':
        non_games_ratings.append(rating)
        
avg_rating_non_games = sum(non_games_ratings) / len(non_games_ratings)
print(avg_rating_non_games)

What I expected to happen:
I expected the code to give a correct output, as I have also rechecked my code with the solution code and I find no mistake in my code.

What actually happened:
I am getting the same error in every mission.

TypeErrorTraceback (most recent call last)
<ipython-input-1-1b32f1b46d32> in <module>()
      2 from csv import reader
      3 read_file = reader(opened_file)
----> 4 apps_data = list(read_file)
      5 non_games_ratings = []
      6 for row in apps_data[1:]:

TypeError: 'list' object is not callable

Is this happening in any specific Mission or the Guided Project?

Because I tried your code in a couple of places and it ran without any such error.

Its happening in for loop and Conditional statements mission.
Even the solution given in help is giving that error.

I am able to run your code without issue on one such Step. It could be a temporary glitch

  1. Try to refresh the page and come back to it after a short while and try again.
  2. If the issue persists, then use the Contact Us link in the top-right of this page to create a ticket for them to look into. Make sure you provide the specific details like the link to the Missions/Mission steps where you face the problem.

Note: For future posts, add the link to the Missions/Mission Steps where you face issues to your post. Without that context it’s difficult to be able to provide any reasonable help.