LIMITED TIME OFFER: 50% OFF OF PREMIUM WITH OUR ANNUAL PLAN (THAT'S $294 IN SAVINGS).
GET OFFER

Issue with formatting .csv to a convinient table

I am a new member. I am having trouble posting questions in any of the discussion groups. I either donot have permissions to post questions or I may be completely lost. Can anyone help me?

Here is my question: Here is the project I am working on: https://www.dataquest.io/blog/how-much-spent-amazon-data-analysis/

I was trying to download a dataset from the following url (https://www.dataquest.io/wp-content/uploads/2019/09/amazon-orders.csv). Find attached .csv file

Data was opened in a new chrome browser so I copied the entire data and downloaded into an excel and changed the format to .csv. amazon-orders.csv (12.1 KB)

When I tried to run the query I donot see the data in table format. (Find attached screenshot)

Can anyone help me how to fix this issue

You seem to have modified the file when you processed it through Excel.

Right right-clicking the link we provided and clicking “Save as” (or something close to this).

Bruno, Thank you for responding to my question.


The problem is I am not able to find ‘Save as’ or similar such thing when I right click. I see ‘copy link address or save link as’ and that doesnt really save as a document. When I click on the hyperlink then the data will open in my chrome browser. So I copied the data from my chrome browser and saved it as a ‘plain text’ in excel and changed the delimiters.

Please find attached screenshot

Hi @simi-1, I have a similar situation although I’m on Ubuntu and not Windows. When I right-click the link, the only “appealing option” is what you have as well: Save Link As... and when you select this option, it defaults to saving it as an HTML file. There is no option to “save file as” or “download file.”

No worries! Please try what worked for me; select Save Link As... and when you get the dialogue box to choose where to save the file and what file name to save it under, simply change the file name to amazon.csv and all should be well! No need to get excel involved.

Best of luck and let me know how you make out.

EDIT:
While the file looked good after download, I wanted to be sure there weren’t any lurking gremlins that would cause an issue for python/pandas so I fired up a jupyter notebook to be absolutely sure. Lookin’ good!

1 Like

Great, Thank you very much for the tip. Let me try that out!

@mathmike314 It worked!! Thank you very very much! Now I can move forward with next steps in the project.

2 Likes