Java SE Development Kit Download for Spark Installation

Hi All,

I’m currently working on installing Java in the Spark Installation And Jupyter Notebook Integration project. When I download JDE from Oracle at the provided link (http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html), it downloads kit version 8u251. When I actually try to run it on my mac, I get an error saying:

“JDK 8 Update 251.pkg” cant be opened because Apple cannot check it for malicious software. The software needs to be updated. Contact the developer for more information.

Is anybody else getting this error? And do you know how to download a version that will open?

Thanks,
Alec

hi @alec

did you google this issue/ error? Please ignore my post if you and have come across these documentation/ forum replies already.

  1. https://www.oracle.com/technetwork/java/javase/using-jdk-jre-macos-catalina-5781620.html
  2. https://www.reddit.com/r/MacOS/comments/cgj1qs/cant_be_opened_because_apple_cannot_check_it_for/

ps. I use windows, so may not be of much help to you.