BLACK FRIDAY EXTRA SAVINGS EVENT - EXTENDED
START FREE

Kernel Dead Error No Reason

KRENEL HAS DIED (need grave diggers!)
Screenshot:

Screen Link:

My Code:

from csv import reader
import datetime as dt

hn = list(reader(open('hacker_news.csv')))
ask_posts = []
show_posts = []
other_posts = []
for post in hn:
    title = post[1]
#     print(title)
    if 'ask hn' in title.lower():
        ask_posts.append(post)
    elif 'show hn' in title.lower():
        show_posts.append(post)
    else:
        other_posts.append(post)
#         print(post)
print("askPosts size : ",len(ask_posts),"showPosts size : ",len(show_posts),"otherPosts size : ",len(other_posts))
total_ask_comments = 0
total_show_comments = 0
for post in ask_posts:
    post[4] = int(post[4])
    total_ask_comments += 1
avg_ask_comments = total_ask_comments/len(ask_posts)
for post in show_posts:
    post[4] = int(post[4])
    total_show_comments += 1
avg_ask_comments = round(total_ask_comments/len(ask_posts),2)
avg_show_comments = round(total_show_comments/len(ask_posts),2)
print(avg_ask_comments,'\n',avg_show_comments,'\n')

result_list = []
counts_by_hour = {}
comments_by_hour = {}
for post in ask_posts:
    value_pair = [post[6],int(post[4])]
    result_list.append(value_pair)
#     print(result_list)
# print(result_list)
for row in result_list:
    hour = dt.datetime.strptime(row[0],"%m/%d/%Y %H:%M")
    hour = hour.strftime("%H")
#     print (hour)
    if hour not in counts_by_hour:
        counts_by_hour[hour] = 1
        comments_by_hour[hour] = result_list[1]
    else:
        counts_by_hour[hour] += 1
        comments_by_hour[hour] += result_list[1]
#         print(comments_by_hour)

# print (counts_by_hour)

What I expected to happen:
I expect the kernel to stay alive (dying is not an answer to any problems in life) or atleast i want it to talk to me. I do a lot of work in life i never quit nor complaint.

What I tried so far:
tried refresh, tried mozilla refresh (shift+refresh), tried clearing kernel and restarting, tried clearing output and code and whole memory and restarting. Nothing worked.
May be my code is a bit too heavy for Jupyter.
Also, I tried reading out other 2 posts similar topic to mine but not helpful so i created a speciic one for mine.

What actually happened:
Kernel Died, wont come alive

Kernel appears to have died. it will re-start automatically.

Course : Python Intermediate
Mission : Guided Project (2) - Exploring Hacker News
Chapter : 5/8

1 Like

Have you solve it yet?

1 Like

nope, but will re-vist later…have diverted for now

1 Like

ok 11 months later re-visintg the same assignment and trying to solve it
and JEEZUZ FROSTBITE CRIES’D this problem still exists???
PFB the screenshot and some1 guide me:-

Unbelievable…the less i think about the bills, the more the bills show off abt themselves (i mean 50 dollars every month for this??)
I did the same assignment from scratch level again and i come across the same thing. I hope you can refer to my Original Post on the Top of this thread for details and granularities. Plz i hope u understand that i dont have to post details again which is why i took a screenshot of the course instead of writing the standard DQ “Love Letter” format.
9Also this is something i encountered in 2018 March during another Jupyter run, but thats not so imp right now)

Thankyou

1 Like

Hi @neo.vandamme1, @raisa.jerin.sristy79 ,

The same thing happened to me with another project on DQ. To avoid such situations, I’d suggest you to work from your local machine (like I myself did since that case). Just install Anaconda on your computer and work from there.

i understand using my system is an alternative.
however, the point of comming to DQ is to be able to have DQ’s system to try it on.
Otherwise i would rather use the books “Learn Python the Hard Way” or other reference material instead of DQ.
Let me understand this correct, So generally DQ calls ppl to become their customers and then tells them to not use DQ associated or related stuff?, ok.

1 Like

Hi @neo.vandamme1,

First of all, I don’t work in DQ, I am just a learner here, just like you. Only that in my free time, I volunteer as a Community moderator here helping students to resolve their technical issues.

I totally understand your frustration about that glitch, because I had the same situation with another project, where I lost a big portion of my hard work. Since then, the workaround for me became using Anaconda. I agree with you that it may be not very convenient, but it can be an alternative solution in any case. Also, I used some other platforms to learn data science, and everywhere there were various glitches, nothing was ideal.

Anyway, I’ll report this bug to the DQ Support Team (by the way, in the future, you can do the same, using the ? in the upper-right corner of the corresponding screen) and will let them know that the students are still suffering from this issue. Hopefully, it will be fixed soon.

2 Likes

This happened to me too. I lost 90% of a guided project on SQL because I wasn’t working on it locally. And although I was mad at DQ for a few days, I realized I was really just mad at myself for putting so much time and effort into something without creating a backup. I have a background in IT and I definitely knew better than to keep only one copy of something you spend that much time on.

2 Likes

That’s a very wise reasoning, Mike, it’s always better to protect your hard work from being lost, in whatever sphere and on whatever platform. After all, none of the systems is impeccable, so it’s better to be proactive on that.

2 Likes

I know you aren’t. I dont think I ever said or suggested you are. You don’t have to help me out. Its your choice and strictly YOUR choice. Also i really appreciate you put your sweat towards this. Thats why i wish that DQ ppl helped me out instead of mods, because i feel bad that mods/other-students-like-me have to draw their time out for me and sacrifice their rate of progress. I think DQ staff should do it, infact they would even get paid for it.
I would rather wish mods got to save all their time and effort behind helping us and instead put all of it on focusing on their own priorities. The achievements will literally double or triple.
(like they say in Airlines : secure yourselves before securing others. mask on yourselves before masking others)

I really wish DQ put their time and effort on us.

Interesting you say you used other platforms and found DQ to be the best of them , then i would assume DQ wouldn’t really have these bugs existing for “4 YEARS”. I am a very understanding guy, and smh a guy like me couldn’t understand this time length. (btw i think its gonna be 5 YEARS next year). but newaz, there is a reason and a good reason that i am not able to have the luxury to use Anaconda or DJANGO or such IDEs/Frameworks. I am trying to make the best of what i have currently and infact i am even spending on it haha.

1 Like

The idea behind this Community (and also many other communties) is exactly to try to resolve your issues and doubts with the help of other learners, whether they are moderators or not. If you want to be helped directly by the DQ workers, then the Communty is a wrong place for you to make a request. Instead, the right way of doing so is to use the ? in the upper-right corner of the corresponding screen and ask your question/make a request/report a bug to the DQ Support Team. Good luck!

5 Likes

Hey, Neo. I work for Dataquest as a content writer.

I’m sorry that this has happened. I completely understand your frustration, I would feel the same in your place.

While this is true, I made a point of surfacing this directly with the team just now. I don’t have the power to act on it and fix it myself, but hopefully, me raising it will find us a solution.

Were you able to connect again?

5 Likes

Thankyou, will do so in future for anything related to non-code or if it feels like non-code.

1 Like

Thankyou, finally some1 in DQ steps in for this.
Yes i was able to connect later however the same “kernel-dead” issue occurs even if i paste the right code instead of the infinity-loop (self-looping) code as pasted above.

There are two cases here:-
-The case pasted in screenshot above, shows that If-Else conditional clause having a sort of list self-looping condition on the dataset “result-list” itself.
-The original post above, shows that even if i write the correct code of non self looping, i still got the “Kernel Dead” issue doing that as well. The following (correct code) did not work either:

for row in result_list:
    hour = dt.datetime.strptime(row[0],"%m/%d/%Y %H:%M")
    hour = hour.strftime("%H")
#     print (hour)
    if hour not in counts_by_hour:
        counts_by_hour[hour] = 1
        comments_by_hour[hour] = row[1]
    else:
        counts_by_hour[hour] += 1
        comments_by_hour[hour] += row[1]
#         print(comments_by_hour)

The reason i decided to execute the self-looping faulty code is just to see if kernel state can be reset or changed by executing different versions of code sequentially from ‘correct’ to ‘infinity loop’ to ‘back to correct would’. Just an old-school Vespa-Motors tilt-to-start technique to see if it kick started after the tilt.
(at noob level skill/knowledge of mine, i could only try such solutions or at the max start praying to computer gods above to send an electric-ray n smh sizzle the circuit to fix the issue)

2 Likes

:laughing:

That this happens to you repeatedly is a weird issue. I’ve communicated that to the team in hopes that we can find a solution.

Hi @neo.vandamme1, the Success team just fixed this issue for you. Can you please confirm if that is indeed the case?

3 Likes

i don’t see the msg any more upon executing the correct code so probably it may have been fixed.
Thankyou

1 Like