Mission Challenge

Screen Link:

My Code:
row_2 = [‘Instagram’, 0.0, ‘USD’, 2161558, 4.5]
row_3 = [‘Clash OF Clans’, 0.0, ‘USD’, 2130805, 4.5]

Replace this line with your code

print(row_2)
type(row_2)
print(row_3)
type(row_3)

What I expected to happen:
[‘Instagram’, 0.0, ‘USD’, 2161558, 4.5]
[‘Clash OF Clans’, 0.0, ‘USD’, 2130805, 4.5]
list

What actually happened:
Output

[‘Instagram’, 0.0, ‘USD’, 2161558, 4.5] [‘Clash OF Clans’, 0.0, ‘USD’, 2130805, 4.5] list

Variables

row_2

row_3

type

Replace this line with the output/error

Hi @olujimiabatan,
I can’t reproduce your output:

Your code

row_2 = ['Instagram', 0.0, 'USD', 2161558, 4.5]
row_3 = ['Clash OF Clans', 0.0, 'USD', 2130805, 4.5]

print(row_2)
type(row_2)
print(row_3)
type(row_3)

Output:

['Instagram', 0.0, 'USD', 2161558, 4.5]
['Clash OF Clans', 0.0, 'USD', 2130805, 4.5]

Actually, the output would be this:

['Instagram', 0.0, 'USD', 2161558, 4.5]
['Clash OF Clans', 0.0, 'USD', 2130805, 4.5]
list

The type(row_3) is displayed as it is that last line of code. But I still do not understand @olujimiabatan’s question.

Thank you for taking time to reply and proffer solution to this question. What i’m saying in other word is that contrary to other previous tasks, whenever i answer correctly, the DashBoard shows NICE WORK but this actual task did not which suggests that my answer has a fault which i happen not to be able to decipher right now.

Thank you fedepereira. My output is exactly the same as what otavios.s posted. But my concern is hat after arriving at this output, I did not get the usual NICE WORK! remark as prior to other tasks that i attempted and solved successfully.

NB: My output after having submitted my answer stated thus
Variables

** row_3**

** row_2**

** type**
without the NICE WORK comment. Thanks

Ok @olujimiabatan, now I think I get your problem. Can you post the link to mission’s screen in which this is happening?

OK @Otavios.s. How do i do that?

Open the mission, go to the screen where this is happening, copy the link on the browser and paste it here.

@olujimiabatan,

I think your error is that you wrongly typed the first element of the list row_3 which you typed as Clash OF Clans. The substring OF in the first element of row_3 should be in lower case not upper case.

Python is case-sensitive and as such Clash OF Clans is not the same as Clash of Clans

Hence, your list row_3 should be:
row_3 = ['Clash of Clans', 0.0, 'USD', 2130805, 4.5]

It should give you the NICE WORK comment after effecting this change.

I hope this helps.

https://app.dataquest.io/m/312/lists-and-for-loops/1/lists

Hey, didn’t @doyinsolamiolaoye’s answer solved your problem?

@doyinsolamiolaoye Thanks for this minute yet very important oversight. You needed to see how frustrated i was with not being able to get the usual accreditation before moving on to the next Mission. I was like being denied a score by your Classroom Lecturer. Lol
Thanks…Proudly Nigerian

Trying it out right now.

Oh ok. If his answer solves your problem, make sure to mark it as solution.

I just tried it now and BINGO!!! IT WORKED!!! Thanks guys. My Bad.

1 Like

I’m glad you got it!

I noticed you marked your own answer as solution. It is important to mark the right answer as solution, in this case @doyinsolamiolaoye’s answer, so users that come to this topic with the same question as you can easily see the solution for it.

1 Like

Oh…Okay! I’ll do just that. Thanks again.

@olujimiabatan,

You are welcome. I am glad I could be of help.
As @otavios.s advised, Kindly ensure that you mark the reply that solves the problem as the solution as this will help others in the community.

Happy learning omo iya mi.

1 Like

Welldone @otavios.s, Thanks for all you do for the DQ community!

Cheers.

1 Like