No module named 'numpy'

I tried to use Numpy locally (MacBook) for the guided project but I failed.
When I import Numpy, I have this error: Traceback (most recent call last): File "<stdin>", line 1, in <module> ModuleNotFoundError: No module named 'numpy'
but when i do : pip3 show numpy
Result : :point_down:t5:
Name: numpy

Version: 1.19.0

Summary: NumPy is the fundamental package for array computing with Python.

Home-page: https://www.numpy.org

Author: Travis E. Oliphant et al.

Author-email: None

License: BSD

Location: /usr/local/lib/python3.7/site-packages

Requires:

Required-by: pandas

Thanks for helping me fix it.

Hi @biadboze,
I can think only in virtual environments. Are you using a virtual environment? Installed Anaconda?

Did you run your code with “python filename.py” or from a text editor?

I’m working on a Jupiter project that I created locally. virtual environment no, for Anaconda I didn’t

All right,
then checkout which kernel have you chosen in Jupyter. It may be running in python 2.

Ok,I will update you

I fixed it, I even open a topic to explain my process to help others. Thks

1 Like

I just moved this topic to the Q&A section.