Pandas read_csv - doesnt seperate after ,

Dear DQ Team,

I try to read a csv file and I want to have it seperated always after the comma.
But it doenst do it.
As you can also see, when I set the sep="," it doesnt work at all.

The Code: Untitled(7).ipynb (14.9 KB)
The CSV: 30300529_WB_Population Density.csv (294.3 KB)

Best and thank you!
Andreas

Click here to view the jupyter notebook file in a new tab

Hello, I’ve checked the csv. it looks as below.

"Data Source","World Development Indicators",

"Last Updated Date","2020-05-19",

"Country Name","Country Code","Indicator Name","Indicator Code","1960","1961","1962","1963","1964","1965","1966","1967","1968","1969","1970","1971","1972","1973","1974","1975","1976","1977","1978","1979","1980","1981","1982","1983","1984","1985","1986","1987","1988","1989","1990","1991","1992","1993","1994","1995","1996","1997","1998","1999","2000","2001","2002","2003","2004","2005","2006","2007","2008","2009","2010","2011","2012","2013","2014","2015","2016","2017","2018","2019",
"Aruba","ABW","Population density (people per sq. km of land 

The fast 2 rows are not important therefore in the pd.read_csv you can use skiprows=2 to skip the rows.

eg

df=pd.read_csv('https://community.dataquest.io/uploads/short-url/xrii4rQyl3N1MlIhA23bUekvx5W.csv', skiprows=2)

I’ve tried it and it runs.

You can read more in the documentation: https://pandas.pydata.org/pandas-docs/stable/reference/api/pandas.read_csv.html

2 Likes

Hi Victor,

just tried and works awesome thank you!!
Best Andi

Am glad I could help. Have a nice day.