The real reason for invalid character in identifier? In reusability and multiple parameters

Screen Link: https://app.dataquest.io/m/315/functions%3A-fundamentals/9/reusability-and-multiple-parameters

My Code:

def freq_table(data_set,index):
frequency_table = {}

for row in data_set[1:]:
    value = row[index]
    if value in frequency_table:
        frequency_table[value] += 1
    else:
        frequency_table[value] = 1
        
return frequency_table

ratings_ft=freq_table(data_set=apps_data, index=7)

What I expected to happen: I expected it to run but no…

What actually happened: error

Replace this line with the output/error

File "<ipython-input-1-012177aedd4c>", line 19
    ratings_ft=freq_table(data_set=apps_data, index=7)
                                  ^
SyntaxError: invalid character in identifier

<!--Enter other details below: -->
apps_data is the given condition why in the end, it became an invalid character.
It is my first time to post my question here, I hope the format is readable. 
Thank you very much !!!

Hi!
The code still needs some formatting. Some lines of code were left as regular text. But anyway it´s possible to read.

The problem is with this line of your code:

I don´t know what parenthesis symbols you used, but when I run it on my terminal I get the same error, but when I delete the parenthesis symbols and input them back using my keyboard the code works as expected :woman_shrugging:

Thank you very much! I use different input keyboard instead of default one. I guess that is very likely the reason.