True instead of NaN in jupyter notebook

screen link: https://app.dataquest.io/m/348/guided-project%3A-clean-and-analyze-employee-exit-surveys/7/identify-dissatisfied-employees

Hi, I am having odd outcomes when I run value_counts(dropna=False) in jupeter notebook.
In previous discussions, this has been covered, but the problem there was related to pandas. Yet I am using jupeter notebook.

Could somebody help me?
Thank you beforehand!

This issue is a pandas 1.0.1 bug: Check more here :point_down:

1 Like

I could not figure out how to change pandas and numpy versions
How can I do so?

In your machine or in DataQuest platform?

Here is the guide for update package - updating a package

And for specific version - installing a different package version

Seems like you’re working on your own machine, so open Anaconda prompt or Windows command prompt (Wnd-R cmd) and type:
conda update pandas
or
conda install -c anaconda pandas

I want to update from 1.0.1 to anything above. So I tried 1.0.5 but the whole process is stuck. In Anaconda navigator it takes like forever saying ’ solving package specifications’. Then I tried anaconda shell with the command, but it is stuck at ‘Solving environment’ stage.

Has anyone faced this issue and how do I go around this?