Upgrading spyder to 5.3.3 is taking over 24 hours and is at 50%

Screen Link:

What I expected to happen:

I’m trying to install Jupyter notebook in Windows 10. I’ve previously installed it in Ubuntu in WSL for Windows 10 and used it for some Newtonian gravity 3 body problem research where I solved a differential equation numerically. Now I’m trying to learn machine learning hopefully. I would love to be able to load my old jupyter notebooks and run them under windows. They’re stored in GitHub. More importantly for this class, I’m on this step in the intro python class for the data science career track right now, where it asks me to install a jupyter notebook using spyder (anaconda). I already have spyder installed, as well as jupyter under windows, which I installed at the command line some months ago in preparation for this class following the instructions on the sign up page. I’m not sure where to find that right now so I can’t give a link.

I expected to be able to install jupyter at the command line then open spyder and run it.

What actually happened:

The first thing I tried, based on the instructions, was

pip install --upgrade pip 
pip3 install jupyter

Unfortunately, pip3 wasn’t found, when I tried to install pip3, that wasn’t found either, and when I ran the second command using pip instead of pip3, jupyter wasn’t found. I saw a recommended solution was

conda install jupyter

Unfortunately, conda wasn’t found at the Windows 10 command line. I then remembered I already had spyder. So I signed in.

When I signed into spyder, it asked me to update to spyder 5.3.3 using

conda update anaconda
conda install spyder=5.3.3

I couldn’t remember spyder’s suggested command when I went to the conda command prompt so I looked up the installation instructions and found them here. I ran

conda update conda
conda update anaconda
conda update spyder

Conda needed to be updated. Anaconda and spyder did not.

I then started spyder. I gave me the information on how to install spyder 5.3.3 again. I ran

conda update conda
conda install spyder=5.3.3

Naturally, conda didn’t need to be updated
However, spyder 5.3.3 is taking over 24 hours to update and is at 50% for examining conflicts. It initially said that it couldn’t do a frozen install and was trying a flexible install, and couldn’t solve the frozen environment, and was trying to solve the flexible environment. Now it has been examining conflicts for more than 24 hours.

I suspect the next step for installing jupyter is

conda install jupyter

But I’m wondering if anyone else has had trouble upgrading spyder to 5.3.3 and if so, what the solution was? I think I have to do this first.

The error is show in the screenshot at the top of this post. My concern is that the installation of spyder 5.3.3 is taking over 24 hours and that the “examining conflicts” step is only 50% done.

Thanks in advance for any help you can give me!

I have 16 GB ram, 2.6 GHz processor, 1 TB solid state hard drive that is nowhere near capacity. Cable internet over wifi. System does seem a bit slow right now so it is possible it is hogging the processor or ram. I’m not sure how to check under windows.

The only thing I can find online is a Github issue about your problem. It seems to be quite common and doesn’t have a definite solution.

The closest to a solution is probably:

I tried
conda remove spyder
and then
conda install spyder=5.3.3
and it seems works. I was using Mac OS at that time.

Some Windows users noted the above does work.

I’m sorry I can’t help more.

1 Like

After 48 hours, at 98%. It says
“examining conflict for asttockens stack_data, anaconda_depends ipython”

The solution was to stop using conda and download the windows installer. It installed spyder/anaconda at the correct version.

3 Likes