Why is it saying these two variables aren't defined?

Screen Link:

My Code:

row_1 = ['Facebook', 0.0, 'USD', 2974676, 3.5]
row_2 = ['Instagram', 0.0, 'USD', 2161558, 4.5]
row_3 = ['Clash of Clans', 0.0, 'USD', 2130805, 4.5]
row_4 = ['Temple Run', 0.0, 'USD', 1724546, 4.5]
row_5 = ['Pandora - Music & Radio', 0.0, 'USD', 1126879, 4.0]


app_data_set = [row_1, row_2, row_3, row_4, row_5]



combined_app_ratings = app_data_set[0][-1] + app_data_set[1][-1] + app_data_set[2][-1] + app_data_set[3][-1] + app_data_set[4][-1]




avg_rating = combined_app_ratings / 5.0

print(app_data_set)
print(avg_rating)

What I expected to happen:

I expected the answer to be accepted!

What actually happened:

    app_data_set isn’t defined in your code, but we expected it to be list type
    avg_rating isn’t defined in your code, but we expected it to be float type

less...

1 Like

Looks fine. Please refresh page and try again.

Thank you for the quick response.

I refreshed the page, but it didn’t work. I logged out, then back in; still no luck.

Thank you for your help either way!

Please share mission link. It would be easy to verify.

Here it is: https://app.dataquest.io/m/422/lists-and-for-loops/6/list-of-lists

Sorry Something wrong from your side. It is working for me.

Odd. I’ll just restart my computer. Why not? haha.

Thank you.

Let us know if it works. :grinning:

It didn’t. On top of that, I went back to older exercises, and the answers that were once correct are now giving similar errors. Very strange. Not sure if there’s anything I need to do on my end.

Ohh! Taging @Sahil He may help you.

1 Like

Thank you!

@Sahil Help! :smiley:

UPDATE: It works now. Thank you.

1 Like